1. #1
    Unregistered

    COM Surrogate has stopped worked in Windows Vista

    Whenever I try to print any document, I receive a message, COM Surrogate has stopped worked. I have been using Windows Vista. How to resolve this issue?



  2. #2
    sweetyilu Array
    Join Date
    Nov 2012
    Posts
    26

    Re: COM Surrogate has stopped worked in Windows Vista

    hello friends...

    Possible Solutions
    • If you are using DivX, you should be upgraded to the very latest version (6.5+)
    • If you are using Nero, you can try upgrading to the latest version (7.7.5.1+)
    • If you’ve upgraded Nero and Divx and still have the problem, you can try renaming the file C:\Program Files\Common Files\Ahead\DSFilter\NeVideo.ax to NeVideo.ax.bak. You may also need to rename NeVideoHD.ax to NeVideoHD.bak
      This will break Nero Showtime, however. (thanks to dugi in the comments for this one)
    • You can disable Thumbnail previews, which should make the problem go away, but isn’t the optimal solution.
    • The older ffdshow codec pack has been known to cause some problems. The ffdshow tryouts codec pack seems to work better. Might want to try using this one: http://ffdshow-tryout.sourceforge.net/
    • If you’d like to uninstall Nero entirely, there is a utility that they provide to help with complete uninstall that helps a lot in instances where you have a bad installation of an older version. http://www.nero.com/nero7/eng/FAQs_N...eroVision.html
    • Some users have recommended installing the Vista Codec Package in order to update all your codecs to the correct versions. I can’t confirm that this works because I have not tried it myself. As always, be careful when installing unknown components and create a restore point.
    • You can use the very useful MMCompView free utility from Nirsoft to disable any codecs on the system. This is very useful to help troubleshoot exactly which component is causing the problem.
    • There’s another possible solution below of turning off DEP for dllhost, which might not work for everybody. You may have to add divx+nero executables to the DEP ignore list.

    Alan McC wrote in with this fix that might solve the problem in a much easier way. Essentially, turning off Data Execution Prevention on dllhost (the COM surrogate) can fix this problem for some people. This solution is detailed below.
    Right click on Computer, and choose Properties

    Click on Advanced System Settings, and then under Advanced, click Settings

    Select the “Data Execution Protection” tab, and then click “Turn on DEP for all programs and services except those I select��?

    Click on the Add button, and then browse to C:\Windows\System32\dllhost.exe as shown

    Click Open, and then OK.
    Here’s what you should see…
    Now you can browse video folders without problems!

    all the best


  3. #3
    mohan123 Array
    Join Date
    Oct 2012
    Posts
    433

    Re: COM Surrogate has stopped worked in Windows Vista

    Dear friends..

    Right click on computer and chose Properties..

    Click on the Advanced tab and on it the Settings..

    Chose anew window popped up..

    Click the Data execution prevention tab..

    Click on Add..

    Navigate to "C:/windows/system32/"and select the "dllhost.exe"file

    Click open..

    Now your problem will solved..

    Thank you and All the best..

+ Reply to Thread

Similar Threads

  1. Photo Gallery has stopped working with Windows Vista
    By Unregistered in forum Windows Forum
    Replies: 9
    Last Post: 13-09-2013, 02:00 PM
  2. Replies: 25
    Last Post: 10-09-2013, 03:42 PM
  3. System Clock stopped working in Windows Vista in Sony laptop
    By Unregistered in forum Windows Forum
    Replies: 22
    Last Post: 15-07-2013, 01:34 AM
  4. Replies: 1
    Last Post: 14-10-2012, 12:38 AM
  5. Replies: 5
    Last Post: 04-09-2012, 10:25 AM